$re = '~\h+\K\p{Lu}+\pL+(?:\h+\pL+)*(?:\h+\([^()]+\))?~m';
$str = 'А здесь у нас Название название (и доп информация)
А здесь у нас Название';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);