const regex = new RegExp('\\h+\\K\\p{Lu}+\\pL+(?:\\h+\\pL+)*(?:\\h+\\([^()]+\\))?', 'gm')
const str = `А здесь у нас Название название (и доп информация)
А здесь у нас Название`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}