import re
regex = re.compile(r"\h+\K\p{Lu}+\pL+(?:\h+\pL+)*(?:\h+\([^()]+\))?", flags=re.MULTILINE)
test_str = ("А здесь у нас Название название (и доп информация)\n"
"А здесь у нас Название")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")