using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""\([^)]*\)""|\s+";
string substitution = @"";
string input = @"First Last ""(Some stuff)""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}