$re = '/"\([^)]*\)"|\s+/';
$str = 'First Last "(Some stuff)"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;