const regex = /"\([^)]*\)"|\s+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"\\([^)]*\\)"|\\s+', 'g')
const str = `First Last "(Some stuff)"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);