using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:width:\s*([\d\.]{1,})).*(?:height:\s*(?:([\d\.]{1,})))";
string input = @"width: 287.942px; height: 162px;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}