re = /(?:width:\s*([\d\.]{1,})).*(?:height:\s*(?:([\d\.]{1,})))/
str = 'width: 287.942px; height: 162px;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end