package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:width:\s*([\d\.]{1,})).*(?:height:\s*(?:([\d\.]{1,})))`)
var str = `width: 287.942px; height: 162px;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}