$re = '/(?:width:\s*([\d\.]{1,})).*(?:height:\s*(?:([\d\.]{1,})))/';
$str = 'width: 287.942px; height: 162px;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);