import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<((?:[a-zA-Z_][\\w\\-\\.]*\\:)?[a-zA-Z_][\\w\\-\\.]*)";
final String string = "<div id=\"app\">\n"
+ " <!-- 这是一个注释节点 -->\n"
+ " <Child name=\"yjc\" :age=\"12\" v-if=\"isShow\"></Child>\n"
+ " <input type=\"text\" v-model=\"inputValue\" />\n"
+ " <div class=\"abc\"></div>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}