import Foundation
let pattern = #"^<((?:[a-zA-Z_][\w\-\.]*\:)?[a-zA-Z_][\w\-\.]*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div id="app">
<!-- 这是一个注释节点 -->
<Child name="yjc" :age="12" v-if="isShow"></Child>
<input type="text" v-model="inputValue" />
<div class="abc"></div>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}