#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<status>(IN|OUT)):\s+"(?<license>[^"]*)"\s+(?<username>[^@]*)@(?<machine>.*)"
Local $sString = "15:21:54 (app1) DENIED: "lic_1" user1@WKS1xxxx (licenses are reserved for others. (-101,396:10054 ""))" & @CRLF & _
"15:21:54 (app1) DENIED: "lic_1" user1@WKS1xxxx (User/host not on INCLUDE list for feature. (-39,349:10054 ""))" & @CRLF & _
"15:21:54 (app1) DENIED: "lic_1" user1@WKS1xxxx (All licenses are reserved for others. (-101,396:10054 ""))" & @CRLF & _
"15:21:54 (app1) DENIED: "lic_1" user1@WKS1xxxx (User/host not on INCLUDE list for feature. (-39,349:10054 ""))" & @CRLF & _
"15:21:54 (app1) DENIED: "lic_1" user1@WKS1xxxx (All licenses are reserved for others. (-101,396:10054 ""))" & @CRLF & _
"15:21:54 (app1) DENIED: "lic_1" user1@WKS1xxxx (User/host not on INCLUDE list for feature. (-39,349:10054 ""))" & @CRLF & _
"15:21:54 (app1) OUT: "lic_1" user1@WKS1xxxx" & @CRLF & _
"15:21:54 (app1) UNSUPPORTED: "lic_2" (PORT_AT_HOST_PLUS ) user1@WKS1xxxx (License server system does not support this feature. (-18,327:10054 ""))" & @CRLF & _
"15:21:54 (app1) UNSUPPORTED: "lic_3" (PORT_AT_HOST_PLUS ) user1@WKS1xxxx (License server system does not support this feature. (-18,327:10054 ""))" & @CRLF & _
"15:21:54 (app1) UNSUPPORTED: "lic_2" (PORT_AT_HOST_PLUS ) user1@WKS1xxxx (License server system does not support this feature. (-18,327:10054 ""))" & @CRLF & _
"15:21:54 (app1) IN: "lic_3" user2@WKS2xxxx" & @CRLF & _
"15:22:04 (app1) IN: "lic_1" user1@WKS1xxxx" & @CRLF & _
"15:22:20 (app1) OUT: "lic_3" user3@WKS22xxx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")