import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<status>(IN|OUT)):\\s+\"(?<license>[^\"]*)\"\\s+(?<username>[^@]*)@(?<machine>.*)";
final String string = "15:21:54 (app1) DENIED: \"lic_1\" user1@WKS1xxxx (licenses are reserved for others. (-101,396:10054 \"\"))\n"
+ "15:21:54 (app1) DENIED: \"lic_1\" user1@WKS1xxxx (User/host not on INCLUDE list for feature. (-39,349:10054 \"\"))\n"
+ "15:21:54 (app1) DENIED: \"lic_1\" user1@WKS1xxxx (All licenses are reserved for others. (-101,396:10054 \"\"))\n"
+ "15:21:54 (app1) DENIED: \"lic_1\" user1@WKS1xxxx (User/host not on INCLUDE list for feature. (-39,349:10054 \"\"))\n"
+ "15:21:54 (app1) DENIED: \"lic_1\" user1@WKS1xxxx (All licenses are reserved for others. (-101,396:10054 \"\"))\n"
+ "15:21:54 (app1) DENIED: \"lic_1\" user1@WKS1xxxx (User/host not on INCLUDE list for feature. (-39,349:10054 \"\"))\n"
+ "15:21:54 (app1) OUT: \"lic_1\" user1@WKS1xxxx\n"
+ "15:21:54 (app1) UNSUPPORTED: \"lic_2\" (PORT_AT_HOST_PLUS ) user1@WKS1xxxx (License server system does not support this feature. (-18,327:10054 \"\"))\n"
+ "15:21:54 (app1) UNSUPPORTED: \"lic_3\" (PORT_AT_HOST_PLUS ) user1@WKS1xxxx (License server system does not support this feature. (-18,327:10054 \"\"))\n"
+ "15:21:54 (app1) UNSUPPORTED: \"lic_2\" (PORT_AT_HOST_PLUS ) user1@WKS1xxxx (License server system does not support this feature. (-18,327:10054 \"\"))\n"
+ "15:21:54 (app1) IN: \"lic_3\" user2@WKS2xxxx\n"
+ "15:22:04 (app1) IN: \"lic_1\" user1@WKS1xxxx\n"
+ "15:22:20 (app1) OUT: \"lic_3\" user3@WKS22xxx";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}