using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<status>(IN|OUT)):\s+""(?<license>[^""]*)""\s+(?<username>[^@]*)@(?<machine>.*)";
string input = @"15:21:54 (app1) DENIED: ""lic_1"" user1@WKS1xxxx (licenses are reserved for others. (-101,396:10054 ""))
15:21:54 (app1) DENIED: ""lic_1"" user1@WKS1xxxx (User/host not on INCLUDE list for feature. (-39,349:10054 ""))
15:21:54 (app1) DENIED: ""lic_1"" user1@WKS1xxxx (All licenses are reserved for others. (-101,396:10054 ""))
15:21:54 (app1) DENIED: ""lic_1"" user1@WKS1xxxx (User/host not on INCLUDE list for feature. (-39,349:10054 ""))
15:21:54 (app1) DENIED: ""lic_1"" user1@WKS1xxxx (All licenses are reserved for others. (-101,396:10054 ""))
15:21:54 (app1) DENIED: ""lic_1"" user1@WKS1xxxx (User/host not on INCLUDE list for feature. (-39,349:10054 ""))
15:21:54 (app1) OUT: ""lic_1"" user1@WKS1xxxx
15:21:54 (app1) UNSUPPORTED: ""lic_2"" (PORT_AT_HOST_PLUS ) user1@WKS1xxxx (License server system does not support this feature. (-18,327:10054 ""))
15:21:54 (app1) UNSUPPORTED: ""lic_3"" (PORT_AT_HOST_PLUS ) user1@WKS1xxxx (License server system does not support this feature. (-18,327:10054 ""))
15:21:54 (app1) UNSUPPORTED: ""lic_2"" (PORT_AT_HOST_PLUS ) user1@WKS1xxxx (License server system does not support this feature. (-18,327:10054 ""))
15:21:54 (app1) IN: ""lic_3"" user2@WKS2xxxx
15:22:04 (app1) IN: ""lic_1"" user1@WKS1xxxx
15:22:20 (app1) OUT: ""lic_3"" user3@WKS22xxx";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}