#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?: *(?:\d+ *(?:y(?:ears?)?|M|mon(ths?)?|w(?:eeks?)?|d(?:ays?)?|h(?:ours?)?|m(?:in(?:ute)?s?)?|s(?:ec(?:ond)?s?)?)))+$"
Local $sString = "1 year 5M 2 weeks 3d 5 hours 50 min 50 secs" & @CRLF & _
"" & @CRLF & _
"1y 5M 3w 5d 23h 59m 50s" & @CRLF & _
"" & @CRLF & _
"1y 5M 2w 3d 5h 50m 50s" & @CRLF & _
"" & @CRLF & _
"5 weeks 2 hours" & @CRLF & _
"" & @CRLF & _
"50s 50 minutes"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")