import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?: *(?:\\d+ *(?:y(?:ears?)?|M|mon(ths?)?|w(?:eeks?)?|d(?:ays?)?|h(?:ours?)?|m(?:in(?:ute)?s?)?|s(?:ec(?:ond)?s?)?)))+$";
final String string = "1 year 5M 2 weeks 3d 5 hours 50 min 50 secs\n\n"
+ "1y 5M 3w 5d 23h 59m 50s\n\n"
+ "1y 5M 2w 3d 5h 50m 50s\n\n"
+ "5 weeks 2 hours\n\n"
+ "50s 50 minutes";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}