package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?: *(?:\d+ *(?:y(?:ears?)?|M|mon(ths?)?|w(?:eeks?)?|d(?:ays?)?|h(?:ours?)?|m(?:in(?:ute)?s?)?|s(?:ec(?:ond)?s?)?)))+$`)
var str = `1 year 5M 2 weeks 3d 5 hours 50 min 50 secs
1y 5M 3w 5d 23h 59m 50s
1y 5M 2w 3d 5h 50m 50s
5 weeks 2 hours
50s 50 minutes`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}