re = /^(?: *(?:\d+ *(?:y(?:ears?)?|M|mon(ths?)?|w(?:eeks?)?|d(?:ays?)?|h(?:ours?)?|m(?:in(?:ute)?s?)?|s(?:ec(?:ond)?s?)?)))+$/m
str = '1 year 5M 2 weeks 3d 5 hours 50 min 50 secs
1y 5M 3w 5d 23h 59m 50s
1y 5M 2w 3d 5h 50m 50s
5 weeks 2 hours
50s 50 minutes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end