#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\b(?<=(^.{0,30}))"
Local $sString = "Lorem ipsum dolor sit amet, consectetur adipiscing elit" & @CRLF & _
"Consectetur adipisicing elit. At quisquam temporibus in tenetur." & @CRLF & _
"Odio ea et doloribus provident omnis? Ab." & @CRLF & _
"Aspernatur cumque dolorum rem, iusto magni eos mollitia porro doloremque incidunt molestiae neque."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")