using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\b(?<=(^.{0,30}))";
string input = @"Lorem ipsum dolor sit amet, consectetur adipiscing elit
Consectetur adipisicing elit. At quisquam temporibus in tenetur.
Odio ea et doloribus provident omnis? Ab.
Aspernatur cumque dolorum rem, iusto magni eos mollitia porro doloremque incidunt molestiae neque.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}