import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\b(?<=(^.{0,30}))";
final String string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit\n"
+ "Consectetur adipisicing elit. At quisquam temporibus in tenetur.\n"
+ "Odio ea et doloribus provident omnis? Ab.\n"
+ "Aspernatur cumque dolorum rem, iusto magni eos mollitia porro doloremque incidunt molestiae neque.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}