const regex = /^.*\b(?<=(^.{0,30}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\b(?<=(^.{0,30}))', 'gm')
const str = `Lorem ipsum dolor sit amet, consectetur adipiscing elit
Consectetur adipisicing elit. At quisquam temporibus in tenetur.
Odio ea et doloribus provident omnis? Ab.
Aspernatur cumque dolorum rem, iusto magni eos mollitia porro doloremque incidunt molestiae neque.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}