const regex = new RegExp('\\pL+\\)\\h*\\K[^<]+', 'gu')
const str = `<span class="tm-p-">ӕ) ӕмӕ уый ахуыр кӕны?</span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}