package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*at\s(?<symbol>[^\r\n\t\f\v (]*?)?(?:\s*)?\(?(?<url>https?:\S+)\:(?<line>\d+):(?<column>\d+)\)?`)
var str = `at (https://s.pinimg.com/mobile/js/pjs-CloseupPage-6b8daa054b87fb85384c.js:1:108083`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}