// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*at\s(?<symbol>[^\r\n\t\f\v (]*?)?(?:\s*)?\(?(?<url>https?:\S+)\:(?<line>\d+):(?<column>\d+)\)?").unwrap();
let string = "at (https://s.pinimg.com/mobile/js/pjs-CloseupPage-6b8daa054b87fb85384c.js:1:108083";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}