#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=<td.*?>)([0-3]?[0-9])\/([0-3]?[0-9])\/((?:[0-9]{2})?[0-9]{2})(?=.*?<\/td>)"
Local $sString = "<table>" & @CRLF & _
"<tr>" & @CRLF & _
"<td class="test">9/2/2021 10:59:15 AM</td>" & @CRLF & _
"</tr>" & @CRLF & _
"" & @CRLF & _
"<tr>" & @CRLF & _
"<td class="test">12/15/2015 12:10:45 PM</td>" & @CRLF & _
"</tr>" & @CRLF & _
"" & @CRLF & _
"<tr>" & @CRLF & _
"<td class="test">10/10/2012 5:00:10 AM</td>" & @CRLF & _
"</tr>" & @CRLF & _
"</table>" & @CRLF & _
""
Local $sSubst = "$1.$2.$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)