import re
regex = re.compile(r"(?<=<td.*?>)([0-3]?[0-9])\/([0-3]?[0-9])\/((?:[0-9]{2})?[0-9]{2})(?=.*?<\/td>)", flags=re.MULTILINE)
test_str = ("<table>\n"
"<tr>\n"
"<td class=\"test\">9/2/2021 10:59:15 AM</td>\n"
"</tr>\n\n"
"<tr>\n"
"<td class=\"test\">12/15/2015 12:10:45 PM</td>\n"
"</tr>\n\n"
"<tr>\n"
"<td class=\"test\">10/10/2012 5:00:10 AM</td>\n"
"</tr>\n"
"</table>\n")
subst = "$1.$2.$3"
result = regex.sub(subst, test_str)
if result:
print(result)