using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<td.*?>)([0-3]?[0-9])\/([0-3]?[0-9])\/((?:[0-9]{2})?[0-9]{2})(?=.*?<\/td>)";
string substitution = @"$1.$2.$3";
string input = @"<table>
<tr>
<td class=""test"">9/2/2021 10:59:15 AM</td>
</tr>
<tr>
<td class=""test"">12/15/2015 12:10:45 PM</td>
</tr>
<tr>
<td class=""test"">10/10/2012 5:00:10 AM</td>
</tr>
</table>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}