#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w+)\s+(\w+)(\(\d*\))?.*$"
Local $sString = "userId bigint(20) NO PRI auto_increment" & @CRLF & _
"createDate datetime YES " & @CRLF & _
"modifiedDate datetime YES " & @CRLF & _
"password_ varchar(75) YES " & @CRLF & _
"passwordEncrypted tinyint(4) YES " & @CRLF & _
"passwordModifiedDate datetime YES " & @CRLF & _
"sAMAccountName varchar(255) YES MUL " & @CRLF & _
"screenName varchar(75) YES UNI " & @CRLF & _
"screenNameModifiedDate datetime YES " & @CRLF & _
"emailAddress varchar(75) YES MUL " & @CRLF & _
"firstName varchar(75) YES " & @CRLF & _
"lastName varchar() YES " & @CRLF & _
"lastLoginDate datetime YES " & @CRLF & _
"active_ tinyint(4) YES MUL " & @CRLF & _
"phone varchar(25) YES " & @CRLF & _
"token varchar(75) YES " & @CRLF & _
"tokenValidUntil datetime YES " & @CRLF & _
"deletedAt datetime YES " & @CRLF & _
"deletedByUserId bigint(20) YES " & @CRLF & _
"eightByEightId varchar(100) YES " & @CRLF & _
"fitPushToken varchar(255) YES " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"-- query 2: " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"WORKORDER_NO varchar(32) NO PRI " & @CRLF & _
"WORKORDER_RES_ID varchar(18) NO PRI " & @CRLF & _
"ATTR_ID varchar(60) NO PRI " & @CRLF & _
"ATTR_NAME varchar(40) NO " & @CRLF & _
"ATTR_DISP_NAME varchar(256) YES " & @CRLF & _
"ATTR_VAL varchar(4000) YES " & @CRLF & _
"CONTROL_TYPE char(1) YES " & @CRLF & _
"DATA_SOURCE text YES " & @CRLF & _
"CONTROL_FLAG char(1) YES " & @CRLF & _
"ATTR_FLAG char(1) NO " & @CRLF & _
"DATA_TYPE char(1) YES " & @CRLF & _
"DATA_LEN int(4) YES " & @CRLF & _
"PRECISION int(2) YES " & @CRLF & _
"SCALE int(2) YES " & @CRLF & _
"IS_NULL char(1) YES " & @CRLF & _
"INIT_VALUE varchar(80) YES " & @CRLF & _
"STATE char(1) NO A " & @CRLF & _
"CREATE_USER decimal(9,0) YES " & @CRLF & _
"CREATE_DATE datetime YES " & @CRLF & _
"MODIFY_USER decimal(9,0) YES " & @CRLF & _
"MODIFY_DATE datetime YES "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")