use strict;
my $str = 'userId bigint(20) NO PRI auto_increment
createDate datetime YES
modifiedDate datetime YES
password_ varchar(75) YES
passwordEncrypted tinyint(4) YES
passwordModifiedDate datetime YES
sAMAccountName varchar(255) YES MUL
screenName varchar(75) YES UNI
screenNameModifiedDate datetime YES
emailAddress varchar(75) YES MUL
firstName varchar(75) YES
lastName varchar() YES
lastLoginDate datetime YES
active_ tinyint(4) YES MUL
phone varchar(25) YES
token varchar(75) YES
tokenValidUntil datetime YES
deletedAt datetime YES
deletedByUserId bigint(20) YES
eightByEightId varchar(100) YES
fitPushToken varchar(255) YES
-- query 2:
WORKORDER_NO varchar(32) NO PRI
WORKORDER_RES_ID varchar(18) NO PRI
ATTR_ID varchar(60) NO PRI
ATTR_NAME varchar(40) NO
ATTR_DISP_NAME varchar(256) YES
ATTR_VAL varchar(4000) YES
CONTROL_TYPE char(1) YES
DATA_SOURCE text YES
CONTROL_FLAG char(1) YES
ATTR_FLAG char(1) NO
DATA_TYPE char(1) YES
DATA_LEN int(4) YES
PRECISION int(2) YES
SCALE int(2) YES
IS_NULL char(1) YES
INIT_VALUE varchar(80) YES
STATE char(1) NO A
CREATE_USER decimal(9,0) YES
CREATE_DATE datetime YES
MODIFY_USER decimal(9,0) YES
MODIFY_DATE datetime YES ';
my $regex = qr/^(\w+)\s+(\w+)(\(\d*\))?.*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}