import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+)\\s+(\\w+)(\\(\\d*\\))?.*$";
final String string = "userId bigint(20) NO PRI auto_increment\n"
+ "createDate datetime YES \n"
+ "modifiedDate datetime YES \n"
+ "password_ varchar(75) YES \n"
+ "passwordEncrypted tinyint(4) YES \n"
+ "passwordModifiedDate datetime YES \n"
+ "sAMAccountName varchar(255) YES MUL \n"
+ "screenName varchar(75) YES UNI \n"
+ "screenNameModifiedDate datetime YES \n"
+ "emailAddress varchar(75) YES MUL \n"
+ "firstName varchar(75) YES \n"
+ "lastName varchar() YES \n"
+ "lastLoginDate datetime YES \n"
+ "active_ tinyint(4) YES MUL \n"
+ "phone varchar(25) YES \n"
+ "token varchar(75) YES \n"
+ "tokenValidUntil datetime YES \n"
+ "deletedAt datetime YES \n"
+ "deletedByUserId bigint(20) YES \n"
+ "eightByEightId varchar(100) YES \n"
+ "fitPushToken varchar(255) YES \n\n\n"
+ "-- query 2: \n\n\n"
+ "WORKORDER_NO varchar(32) NO PRI \n"
+ "WORKORDER_RES_ID varchar(18) NO PRI \n"
+ "ATTR_ID varchar(60) NO PRI \n"
+ "ATTR_NAME varchar(40) NO \n"
+ "ATTR_DISP_NAME varchar(256) YES \n"
+ "ATTR_VAL varchar(4000) YES \n"
+ "CONTROL_TYPE char(1) YES \n"
+ "DATA_SOURCE text YES \n"
+ "CONTROL_FLAG char(1) YES \n"
+ "ATTR_FLAG char(1) NO \n"
+ "DATA_TYPE char(1) YES \n"
+ "DATA_LEN int(4) YES \n"
+ "PRECISION int(2) YES \n"
+ "SCALE int(2) YES \n"
+ "IS_NULL char(1) YES \n"
+ "INIT_VALUE varchar(80) YES \n"
+ "STATE char(1) NO A \n"
+ "CREATE_USER decimal(9,0) YES \n"
+ "CREATE_DATE datetime YES \n"
+ "MODIFY_USER decimal(9,0) YES \n"
+ "MODIFY_DATE datetime YES ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}