package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bcar\s*\([^()]+\)`)
var str = `Only one car(52;model-14557) had a good engine(workable condition), others engine were damaged beyond repair
Other car(21, model-155) looked in good condition but car ( 36, model-8878) looked to be in terrible condition.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}