const regex = /\bcar\s*\([^()]+\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bcar\\s*\\([^()]+\\)', 'g')
const str = `Only one car(52;model-14557) had a good engine(workable condition), others engine were damaged beyond repair
Other car(21, model-155) looked in good condition but car ( 36, model-8878) looked to be in terrible condition.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}