use strict;
my $str = 'Only one car(52;model-14557) had a good engine(workable condition), others engine were damaged beyond repair
Other car(21, model-155) looked in good condition but car ( 36, model-8878) looked to be in terrible condition.';
my $regex = qr/\bcar\s*\([^()]+\)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}