import Foundation
let pattern = #"\bcar\s*\([^()]+\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Only one car(52;model-14557) had a good engine(workable condition), others engine were damaged beyond repair
Other car(21, model-155) looked in good condition but car ( 36, model-8878) looked to be in terrible condition.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)