#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[([^][\r\n]*)][^\S\r\n]+([^:\r\n]+):(.*(?:\r?\n {4}.*)*)"
Local $sString = "[chat] somebody: this is some text that needs to be matched." & @CRLF & _
" it continues on this line with four spaces at the bottom" & @CRLF & _
" and its also on this line." & @CRLF & _
"It should not match this line" & @CRLF & _
" " & @CRLF & _
"[chat] somebody: this is more text, but only one line." & @CRLF & _
"This should not be matched"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")