import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[([^][\\r\\n]*)][^\\S\\r\\n]+([^:\\r\\n]+):(.*(?:\\r?\\n {4}.*)*)";
final String string = "[chat] somebody: this is some text that needs to be matched.\n"
+ " it continues on this line with four spaces at the bottom\n"
+ " and its also on this line.\n"
+ "It should not match this line\n"
+ " \n"
+ "[chat] somebody: this is more text, but only one line.\n"
+ "This should not be matched";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}