import Foundation
let pattern = #"^\[([^][\r\n]*)][^\S\r\n]+([^:\r\n]+):(.*(?:\r?\n {4}.*)*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[chat] somebody: this is some text that needs to be matched.
it continues on this line with four spaces at the bottom
and its also on this line.
It should not match this line
[chat] somebody: this is more text, but only one line.
This should not be matched
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)