using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[([^][\r\n]*)][^\S\r\n]+([^:\r\n]+):(.*(?:\r?\n {4}.*)*)";
string input = @"[chat] somebody: this is some text that needs to be matched.
it continues on this line with four spaces at the bottom
and its also on this line.
It should not match this line
[chat] somebody: this is more text, but only one line.
This should not be matched";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}