import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([^\\s]+).*?id=\"opensource\".*?>(?:\\s+)?(.+?)(?:\\s+)?<\\/\\1>";
final String string = " <article id=\"opensource\">Cabby </article>\n\n\n"
+ " <article id=\"opensource\">\n"
+ " Cabby\n"
+ " </article>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}