re = /<([^\s]+).*?id="opensource".*?>(?:\s+)?(.+?)(?:\s+)?<\/\1>/m
str = ' <article id="opensource">Cabby </article>
<article id="opensource">
Cabby
</article>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end