$re = '/<([^\s]+).*?id="opensource".*?>(?:\s+)?(.+?)(?:\s+)?<\/\1>/m';
$str = ' <article id="opensource">Cabby </article>
<article id="opensource">
Cabby
</article>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);