#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:--.*)|(?:\/\*)+?[\w\W]+?\n\*\/"
Local $sString = "--GO" & @CRLF & _
"--SET ANSI_NULLS ON" & @CRLF & _
"--GO" & @CRLF & _
"--SET QUOTED_IDENTIFIER ON" & @CRLF & _
"--GO" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
" DECLARE @Gas SMALLDATETIME = '1/1/2016'," & @CRLF & _
" @System VARCHAR(Max) = '30',--'12,76,466,465,30,226'," & @CRLF & _
" /*following param is to help decide Transportation or Storage */" & @CRLF & _
" @Contract INT = 0,--Transport or (1 = storage). " & @CRLF & _
" /*following param is to help decide dth or %*/" & @CRLF & _
" -- Contract Period 0 = 5 Years, 1 = 10 years,..., 4=25 years" & @CRLF & _
" " & @CRLF & _
"*/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")