re = /(?:--.*)|(?:\/\*)+?[\w\W]+?\n\*\//m
str = '--GO
--SET ANSI_NULLS ON
--GO
--SET QUOTED_IDENTIFIER ON
--GO
/*
DECLARE @Gas SMALLDATETIME = \'1/1/2016\',
@System VARCHAR(Max) = \'30\',--\'12,76,466,465,30,226\',
/*following param is to help decide Transportation or Storage */
@Contract INT = 0,--Transport or (1 = storage).
/*following param is to help decide dth or %*/
-- Contract Period 0 = 5 Years, 1 = 10 years,..., 4=25 years
*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end