using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:--.*)|(?:\/\*)+?[\w\W]+?\n\*\/";
string input = @"--GO
--SET ANSI_NULLS ON
--GO
--SET QUOTED_IDENTIFIER ON
--GO
/*
DECLARE @Gas SMALLDATETIME = '1/1/2016',
@System VARCHAR(Max) = '30',--'12,76,466,465,30,226',
/*following param is to help decide Transportation or Storage */
@Contract INT = 0,--Transport or (1 = storage).
/*following param is to help decide dth or %*/
-- Contract Period 0 = 5 Years, 1 = 10 years,..., 4=25 years
*/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}