import re
regex = re.compile(r"(?:--.*)|(?:\/\*)+?[\w\W]+?\n\*\/", flags=re.MULTILINE)
test_str = ("--GO\n"
"--SET ANSI_NULLS ON\n"
"--GO\n"
"--SET QUOTED_IDENTIFIER ON\n"
"--GO\n\n"
"/*\n"
" DECLARE @Gas SMALLDATETIME = '1/1/2016',\n"
" @System VARCHAR(Max) = '30',--'12,76,466,465,30,226',\n"
" /*following param is to help decide Transportation or Storage */\n"
" @Contract INT = 0,--Transport or (1 = storage). \n"
" /*following param is to help decide dth or %*/\n"
" -- Contract Period 0 = 5 Years, 1 = 10 years,..., 4=25 years\n"
" \n"
"*/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")