# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\$|\G(?!^))\d+\K,(?=\d)//gm;t' <<< "apple with make,up things $312,412,3.00"