re = /(?:\$|\G(?!^))\d+\K,(?=\d)/m
str = 'apple with make,up things $312,412,3.00'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result