$re = '/(?:\$|\G(?!^))\d+\K,(?=\d)/m';
$str = 'apple with make,up things $312,412,3.00';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;